Frequently Asked Question - Questions related to Geocode Factory 3 bubbles

Questions related to Geocode Factory 3 bubbles

1 The links into bubbles point to a page with a login form.

Hello, this is due because the Geocode Factory search the first link over the target component in the database. If this link is an admin (or member link) the login form is shown.

Then we need to speciphy the correct component Joomla itemid for the correct menu target page context. Edit the markerset you use and enter the correct itemid.

You find the itemid in the Joomla menu manager or in your sef component. Insert this nueric value into the Geocode Factory markerset option 'Menu itemid'.

2 My bubble is not centered when I open it, specially when I have an image into the bubble.

This is due because the image is loaded to slowly reagarding the bubble (we speak about mirco-seconds). Then if the image is too heigth the bubble size is calculated without counting this height (because the image is not yet loaded), and bubble is misplaced.

One workaround is to set an 'artificialy' height to the image before she is loaded. If the images are always the same height add this to the bubble template into the image tag : style="height:180px;" (180 is the image height), and if images size are variables, use this style="min-height:180px;" (180 is an estimated average height)

3 When I click on a marker, the bubble load, and before the content is displayed the bubble is closed.

This is probably due because the bubble don't have any template. You need to create a bubble template to be sure that the bubble can be loaded.

See the getting started quide to learn how to create a bubble template.

4 Why the images or links wont work in my bubbles?

Because when you insert a [IMAGE] or [IMAGE_xxx] placeholder, only the path on the image is inserted (because Geocode Factory do not know the usage you will use for it).

Then to show the image you need to use this placeholder like this : <img src="/[IMAGE]".

For the links is the same, you need to use is like : <a href="/[LINK_field_website]" or  <a href="http://[LINK_field_website]".

5 - My bubble is no more loading or loading like this image?

The bubbles are empty because there has been a change in the google API (used for displaying google maps). The problem occurs when you have not set a bubble width into your Markerset(s). You have 3 solutions to fix this issue:

  • edit each markerset and on the first tab, set a width to the bubble, like 300
  • or... if you have a lot of markersets...
  • Update the database
    • In your host cpanel, access your phpmyadmin interface
    • send this query: UPDATE `jos_geocode_factory_parametres` SET valeur=300 WHERE keynom='bubblewidth'
    • the table prefix jos_ can be different
  • or
  • Edit the source code
    • In this file 'the components/com_geocode_factory/models/dataxml.php' around line 1790
    • change: $tmp->width = $oListMarker->bubblewidth ;
    • to: $tmp->width = (isset($oListMarker->bubblewidth) && ((int)$oListMarker->bubblewidth>0))?intval($oListMarker->bubblewidth):200 ;